QCE - Connectivity issue with Chrysler EMTS

Incident Report for QAD System

Resolved

This incident has been resolved.
Posted Sep 20, 2026 - 16:27 UTC

Investigating

We are currently investigating this issue.
Posted Sep 20, 2026 - 15:54 UTC
This incident affected: QAD Cloud EDI (QCE) (QCE Trading Partners Connections).