GECHub was doing product upgrade on 7-June-2026. The Sunday maintenance window extended to 4pm EST. Any data exchange between 4am and 4pm EST was impacted. Please report any issues via helpdesk. Suppliers are requested to Post the Manual ASN until GEC-HUB is up. IT Advisory #105885 ** Revised estimate to complete upgrade is 8pm EST **
Posted Jun 08, 2026 - 19:38 UTC
Resolved
This incident has been resolved. GECHub did a product upgrade on 7-June-2026, during the extended maintenance windows on Sunday.
Notification on https://www.gtpcm.ford.com/Home "GECHub is doing product upgrade on 7-June-2026. The Sunday maintenance window will be extended to 4pm EST. Any data exchange between 4am and 4pm EST will be impacted. Please report any issues via helpdesk. Suppliers are requested to Post the Manual ASN until GEC-HUB is up. IT Advisory #105885 ** Revised estimate to complete upgrade is 8pm EST **"
Posted Jun 08, 2026 - 19:32 UTC
Investigating
We are currently investigating this issue.
Posted Jun 07, 2026 - 08:25 UTC
This incident affected: QAD Cloud EDI (QCE) (QCE Service, QCE Trading Partners Connections).