Digital Commerce Security Incident

Incident Report for QAD System

Update

We are continuing to work on a fix for this issue.
Posted Jul 29, 2025 - 16:28 UTC

Identified

The issue has been identified and our system administrators are working closing with the security team to implement the solution in a coordinated rollout to the impacted customer devices.
Posted Jul 29, 2025 - 15:04 UTC

Investigating

Our security team has observed suspicious activity with our Digital Commerce solution effecting a subset of customers. As a precautionary measure, the servers have been quarantined and are currently under investigation. The security team is actively working to gather more information and will keep customers informed of any significant updates as the investigation progresses.
If customers are experiencing an issue please log a support incident and our support staff will investigate and determine if the issues are related.
Posted Jul 29, 2025 - 14:13 UTC
This incident affects: Digital Commerce (Digital Commerce - US Dallas).